No. 2 Texas dominates Incarnate Term, 12-0


b308: shotgunstan69 you need to reflash the firmware, i.e. connect to PC via cable, download the flashing app and firmware files Oct 8, 2022 5:27:16 GMT -8
tstamos: Just got a x sight 4k scope and it kept freezing so updated it and now I’ve no menu or when trying to switch off the ok button not responding. turns on fine but i cant use the OK button because it wont respond Oct 11, 2022 18:21:17 GMT -8
tstamos: any help or tips? Oct 11, 2022 18:21:48 GMT -8
timsjohn: Hello Tim, this site I want to purchase a night vision scope which scope is the best. Oct 12, 2022 3:00:52 GMT -8
rickyblaze: You might try this Oct 13, 2022 9:23:48 GMT -8
gandabeatty: Hi, my name is Glen and I’m from Western Australia. I mostly hunt foxes, cats, rabbits and kangaroos. I’ve recently bought an ATN LTV 5-15. Seems to be a good scope. Having a few problems with whiteout from the illuminator so I’m hoping for guidance. Oct 16, 2022 5:58:47 GMT -8
toby702: Are there instructions for updating the firmware on the Thor LT? Oct 18, 2022 14:48:28 GMT -8
partsrunner1: thanks Oct 20, 2022 11:29:12 GMT -8
jer80age: i am trying to register my thor scope! Oct 24, 2022 11:37:01 GMT -8
kbailey45us: Got my new Thor 4 today. Loved it for the 3-4 hours it worked now it wont turn on. Pathetic!!!!! Oct 24, 2022 18:36:46 GMT -8
rickyblaze: have you tried holding the power button down for over 30 seconds? Mine did something like that while I was using it right after I got it. I just held the power button down until it came back on and haven't had the problem again Oct 25, 2022 10:33:02 GMT -8
77americanskier: 4k pro freezes up constantly after update Oct 27, 2022 6:02:56 GMT -8
kshunt: atn thor 4 thermal haS ERR AT TOP OF SCENE but cant find what the err stands for , even thou campass is stuck on north an when trying to sight in dont even hit target at 100 yds 6ft low thats way to much how to fix both . do have correct device Type Nov 3, 2022 5:59:19 GMT -8
alwilliams: I have tried and tried to get mine into the cal mode but no luck, any suggestions? Nov 13, 2022 6:44:24 GMT -8
michaelt: USB-C port on my 4K Pro has "disappeared". Any suggestions? Nov 15, 2022 14:41:46 GMT -8
dirtyboots801: when i try to update firmware, the sd card blinks red and then steady green but no prompt to update firmware appears Nov 18, 2022 9:43:13 GMT -8
dirtyboots801: tried 3 cards (16/32/32) from 2 brands (sandisk/MC) and all are class 10 HC Nov 18, 2022 9:43:55 GMT -8
dirtyboots801: long and short and in scope formats dont change the results Nov 18, 2022 9:44:16 GMT -8
gregzak: Hi all, Nov 28, 2022 14:11:23 GMT -8
gregzak: I've been shooting for 67 years and purchased my first ATN product a few days ago. I'm in the process now of doing my first firmware update. Nov 28, 2022 14:13:55 GMT -8
Shout as:
  • Bold
  • Italic
  • Underline
  • Strikethrough
  • Link
  • Insert Smiley
0/256 Send Cancel